Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Temperature profile around a plasmonic substrate

Please login with a confirmed email address before reporting spam

I am trying to simulate the temperature profile around a plasmonic gold plate in 2D surrounded by water. I am using 2 modules ewfd and ht in solids and fluids. The input field is getting totally internally reflected at the glass-water interface. The water surrounding the gold plate is open to the air and is initially at the same temperature as the surrounding. I am running a stationary study. I expect the temperature of the gold to be significantly larger than the surrounding water as the thermal conductivity of the gold is much larger than the water. But the temperature difference between the gold and the water is approx 0.02 K. Please let me know about the possible mistake in the implementation of the module and how to move forward from here.

Also when I run a time dependent study, the temperature keeps on increasing and never equilibrates.



1 Reply Last Post 6 Feb 2020, 04:01 GMT-5
Lars Dammann COMSOL Employee

Please login with a confirmed email address before reporting spam

Posted: 8 months ago 6 Feb 2020, 04:01 GMT-5

Hi, have you tried actually computing the flow of the water, i.e. natural convection? Usually the cooling is much larger that way. See the examples form the Heat Transfer Module, especially Buoyoncy of Water: https://www.comsol.com/model/buoyancy-flow-in-water-13683 and Natural Convection of a Vacuum Flask: https://www.comsol.com/model/natural-convection-cooling-of-a-vacuum-flask-1448

I also have some general comments regarding your model: You are solving for all three vector components of the electric field, but the z-component is zero everwhere in your model. So it would reduce the simulation time to not compute that at all. To do that, select the ewfd node and change the setting for the components solved for to "in-plane".

Another point is that your mesh is a bit too coarse in some regions. It is not enough to use the finest predefined setting here, you should use user-defined size nodes and explicitly set the maximum element size to 1/6 of a wavelength in that material. You always need to properly resolve the waves in your medium!

You also have your heat source added twice. The Electromagnetic Heating node already adds the heat source, you do not need to add another heat source to the ht interface.

It is worth trying out if it is necessary to compute the fields in your gold layer. The field probably do not penetrate very deeply into the metal. If the penetration depth of the fields is much smaller than the thickness of the layer, you could use an impedance boundary condition or a transition boundary condition instead. It may be more accurate that way.

I fixed the smaller mistakes and turned the two physics into two study steps to save time. This neglects the backcoupling of the temperature onto the electric fields, but it seems to me there is no coupling in that direction anyway. File attached.

Hope that helps. Best wishes, Lars

Hi, have you tried actually computing the flow of the water, i.e. natural convection? Usually the cooling is much larger that way. See the examples form the Heat Transfer Module, especially Buoyoncy of Water: https://www.comsol.com/model/buoyancy-flow-in-water-13683 and Natural Convection of a Vacuum Flask: https://www.comsol.com/model/natural-convection-cooling-of-a-vacuum-flask-1448 I also have some general comments regarding your model: You are solving for all three vector components of the electric field, but the z-component is zero everwhere in your model. So it would reduce the simulation time to not compute that at all. To do that, select the ewfd node and change the setting for the components solved for to "in-plane". Another point is that your mesh is a bit too coarse in some regions. It is not enough to use the finest predefined setting here, you should use user-defined size nodes and explicitly set the maximum element size to 1/6 of a wavelength in that material. You always need to properly resolve the waves in your medium! You also have your heat source added twice. The Electromagnetic Heating node already adds the heat source, you do not need to add another heat source to the ht interface. It is worth trying out if it is necessary to compute the fields in your gold layer. The field probably do not penetrate very deeply into the metal. If the penetration depth of the fields is much smaller than the thickness of the layer, you could use an impedance boundary condition or a transition boundary condition instead. It may be more accurate that way. I fixed the smaller mistakes and turned the two physics into two study steps to save time. This neglects the backcoupling of the temperature onto the electric fields, but it seems to me there is no coupling in that direction anyway. File attached. Hope that helps. Best wishes, Lars

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.