Patch for MATLAB 2010a support and Snow Leopard support

Released May 4, 2010.

This patch adds compatibility with MATLAB 2010a. The Macintosh patch also adds compatibility with Mac OS X 10.6 Snow Leopard. The patch is cumulative and replaces any earlier 3.5a patches for MATLAB support.

Installation

Before You Begin

Make sure you have applied the COMSOL 3.5a hotfix 1 before applying this patch. On the Help menu, click "About COMSOL Multiphysics" and make sure you have version 3.5.0.608. If you do not, you need to apply the hotfix 1 before you continue.

Linux

Download the patch file comsol_3.5.0.608-p3_linux.patch. Connect to the COMSOL installation directory, for example, /usr/local/comsol35a (type cd /usr/local/comsol35a). Type the following commands:

  • patch -Rf -p1 < [download file path]/comsol_3.5.0.608-p3_linux.patch > /dev/null
  • patch -p1 < [download file path]/comsol_3.5.0.608-p3_linux.patch

Mac OS X

This update also adds support for Mac OS X 10.6 Snow Leopard.

  • Download the file comsol_3.5.0.608-p3_mac.dmg.
  • If it does not mount automatically, double-click the dmg file to mount it.
  • Double-click COMSOL Installer to launch the installer. If your COMSOL installation is not in the default location in the Applications folder, the installer will ask you to locate the COMSOL installation folder.
  • When the installation is selected, click Install to start the installation.

Windows

Download and run the file comsol_3.5.0.608-p3_win.exe. Unzip the contents in the COMSOL installation directory, for example C:\COMSOL35a.

Check the Installation

This patch does not increment the build number. On Macintosh Snow Leopard, start COMSOL and make an arbitrary plot. Connect to MATLAB 2010a. On Linux or Windows, connect COMSOL to MATLAB 2010a. If no error messages are displayed you have successfully updated the software.